解决docker客户端版本过高问题

2019年3月23日 发表评论 阅读评论

使用go 语言 docker api进行测试编程时,会遇到“Error response from daemon: client version 1.4 is too new. Maximum supported API version is 1.39”的问题,
原因是因为api现在最多只能支持到1.39,但是我们的client是1.4,具体版本根据错误提示判断。 下面分别告诉大家如何在Linux和Windows中解决这个问题:

Linux(CentOS,Ubuntu等):

修改 /etc/profile 和 ~/.bashrc 文件,在两个文件最后分别追加:

export DOCKER_API_VERSION=1.39

Windows:

如果安装了docker toolbox,打开 Docker Quickstart Terminal ,在此终端输入

export DOCKER_API_VERSION=1.39

http://it.dengchao.org
声明: 本文采用 BY-NC-SA 协议进行授权. 转载请注明转自: 解决docker客户端版本过高问题
  1. 本文目前尚无任何评论.
  1. 本文目前尚无任何 trackbacks 和 pingbacks.